Differences

This shows you the differences between two versions of the page.

Link to this comparison view

sony-vaio-z [2013/03/04 22:08] (current)
a created
Line 1: Line 1:
 +> Here is what I did to install the Qualcomm 3 G modem on my Z31 (Ubuntu 9.04 
 +> Jaunty). From several sources, thanks to all. 
 +
 +> 1. install qcserial module (maybe not necessary anymore in 9.10) 
 +
 +> copy qserial.c et Makefile from 
 +> http://​vaioz31.blogspot.com/​2009/​04/​3g-support-qualcomm-gobi-chipset-step1.html 
 +> make 
 +> sudo make install 
 +
 +> 2. install gobi_loader 
 +
 +> download from http://​www.codon.org.uk/​~mjg59/​gobi_loader/<​http://​www.codon.org.uk/​%7Emjg59/​gobi_loader/>​ 
 +> make 
 +> sudo make install 
 +
 +> 3. install firmware 
 +
 +> Boot in Windows, look for the right driver for your region in C:​\Documents 
 +> and Settings\All Users\Application Data\QUALCOMM\QDLService\Options.txt 
 +> then copy amss.mbn et apss.mbn from the corresponding directory (the one 
 +> listed in Options.txt) to /​lib/​firmware/​gobi that you have to create in 
 +> Ubuntu using administrative privileges 
 +
 +> 4. reload qcserial 
 +
 +> sudo modprobe -r qcserial 
 +> sudo modprobe qcserial 
 +
 +> 5. To activate the modem and make it load the driver when I want ot use it, 
 +> I use the following script with the Wireless switch on the ON position ( 
 +> https://​lists.launchpad.net/​sony-vaio-z-series/​msg00411.html):​ 
 +
 +> #!/bin/sh 
 +> echo 0 > /​sys/​class/​rfkill/​rfkill2/​state 
 +> sleep 1 
 +> modprobe -r qcserial 
 +> #modprobe -r usbserial 
 +> #modprobe usbserial vendor=0x05c6 product=0x9222 
 +> #modprobe usbserial 
 +> modprobe qcserial 
 +> echo 1 > /​sys/​class/​rfkill/​rfkill2/​state 
 +
 +> Then the modem appear in network-manager and you can configure the 
 +> connection with your 3G provider'​s settings. 
 +
 +> Hope this helps. Nothing new. Just compilation of different informations. 
 +
 +> Regards,
sony-vaio-z.txt · Last modified: 2013/03/04 22:08 by a
CC Attribution-Noncommercial-Share Alike 4.0 International
Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0 ipv6 ready